Issue receiving support emails
Incident Report for Instaclustr
Resolved
This incident has been resolved.
Posted Sep 01, 2020 - 00:01 UTC
Monitoring
The issues appears to be resolved. We do not believe we have lost any emails but please feel free to resend or contact us via chat if you are waiting for reply.
Posted Aug 31, 2020 - 21:04 UTC
Investigating
We are currently experiencing issues receiving emails at support@instaclustr.com email address. Please use the web form or chat at support.instaclustr.com if you need to contact us.
Posted Aug 31, 2020 - 20:57 UTC