GCP us-west1 Operational Issues

Incident Report for Instaclustr

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 19:46 UTC

Monitoring

Google have completed mitigations and are reporting recovery across multiple products. We will continue monitoring the incident until the remaining products have recovered.
Vertical scaling remains disabled in us-west1.
Posted Aug 20, 2026 - 19:06 UTC

Update

Vertical scaling has been temporarily disabled in the GCP us-west1 region due to this cloud provider outage. We will re-enable this functionality when the cloud provider outage is resolved.
Posted Aug 20, 2026 - 17:58 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 20, 2026 - 17:16 UTC

Identified

We are currently experiencing service degradation and potential disruptions in the Google Cloud Platform region us-west1. This incident is a result of an ongoing issue with the cloud provider's infrastructure.

You will be unable to provision new clusters or nodes. Existing nodes in us-west1 may be unavailable. Cluster datacentres in other regions are unaffected, but are experiencing networking issues when interacting with nodes in us-west1. Individual impacted customers are being contacted via support tickets.

We are actively monitoring the situation and will provide additional details as they become available. GCP status is tracked at https://status.cloud.google.com/.

If you have an urgent matter, please reach out to us via the support portal (support.instaclustr.com) or email (support@instaclustr.com).
Posted Aug 20, 2026 - 17:15 UTC
This incident affected: Cluster Management API, Terraform Provider, Google Cloud Platform Google Cloud Storage, and Google Cloud Platform Google Compute Engine.