support.instaclustr.com down
Incident Report for Instaclustr
Resolved
This incident has been resolved.
Posted about 1 year ago. Jun 02, 2018 - 02:11 UTC
Monitoring
We believe the issue is now resolved and are verifying.
Posted about 1 year ago. Jun 01, 2018 - 21:53 UTC
Investigating
We are investigating issues connecting to support.instaclustr.com.

This seems to be localized to the support portal only, and we can confirm that we are still receiving emails sent to support@instaclustr.com.
Posted about 1 year ago. Jun 01, 2018 - 20:08 UTC
This incident affected: Support Portal.