403 Forbidden errors when accessing Cluster-Level Prometheus Monitoring Queries

Incident Report for Instaclustr

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 09:48 UTC

Monitoring

A fix is being rolled out and we are monitoring the results.
Posted Jul 16, 2026 - 08:52 UTC

Update

The issue has been identified, and our team is actively working on implementing a fix. Cluster-level Prometheus monitoring query requests are being incorrectly blocked with a 403 error. Other Prometheus monitoring queries are unaffected.

Existing customer clusters are unaffected. The Management Console and Cluster Management API are still operational.

We will provide updates as soon as they become available. If you have an urgent matter, please reach out to us via the support portal (support.instaclustr.com) or email (support@instaclustr.com).
Posted Jul 16, 2026 - 04:52 UTC

Identified

We are currently investigating an issue causing cluster level Prometheus monitoring query requests to be incorrectly blocked with a 403 error. Other Prometheus monitoring queries are unaffected. Our team is actively working to resolve the issue, and we apologise for any inconvenience caused.

The Management Console, Cluster Management API and Monitoring API are still operational.

We will provide updates as soon as they become available. If you have an urgent matter, please reach out to us via the support portal (support.instaclustr.com) or email (support@instaclustr.com).
Posted Jul 16, 2026 - 04:34 UTC
This incident affected: Monitoring API.