Support Email Service Degradation
Incident Report for Instaclustr
Resolved
This incident has been resolved.
Posted Aug 21, 2024 - 06:43 UTC
Identified
We are aware that some users may be experiencing issues sending emails to our support email (support@instaclustr.com) due to a problem with an upstream provider. Our team is currently investigating the problem and we apologise for any inconvenience caused.

New and existing customer clusters are unaffected.

Additional details will be provided as they become available. If you have an urgent matter, please create a ticket through support.instaclustr.com.
Posted Aug 20, 2024 - 23:25 UTC