Delayed email for support@instaclustr.com
Incident Report for Instaclustr
Resolved
The issue with the underlying provider is now resolved.

Our support portal is available again and emails are being received as normal.
Posted Mar 16, 2017 - 01:18 UTC
Identified
Our underlying provider Zendesk is experiencing an outage which is affecting our support portal. This has resulted in delayed email to our support address.

See https://status.zendesk.com/#instaclustr for updates
Posted Mar 15, 2017 - 21:36 UTC